Andesi - forum

Forum francophone pour Debian

Vous n'êtes pas identifié(e).

#1 19/11/2013 23:51:28

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Flash : Dépassement matériel !

Bonjour,

Suite à la dernière mise à jour je ne peux plus lire de vidéos en ligne !

Maintenant Iceweasel est en version 17.0.9

et son plugin Flash (  Adobe ) est en version 11,2,202,327

En cherchant il apparaît que cela est normal : J'ai maintenant dépassé les limites de mon vieux PC !
( AMD Duron cadencé à 1,6 GHz ) puisque Adobe recommande au minimum un Processeur compatible x86 à 2,33 GHz !

Il se peut aussi qu'il y ait une incompatibilité entre le navigateur et le plugin (les deux viennent d'être mis à jour) mais il me semble que cela s'auto-contrôle, non ?

Le « flashplugin-nonfree » , paquet disponible sur les sources wheezy est dernière version 1:3.2 correspondant bien à la version éditeur  11,2,202,327 du plugin.

Bref,
Existe-t-il une solution pour revenir en arrière ? (Cela devrait résoudre mon problème, je pense.)

Hors ligne

#2 20/11/2013 10:21:59

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Flash : Dépassement matériel !

Salut,

Je dirais d'aller chercher le plugin dans les dépots de squeeze (ou de la version précédente qui va bien) et l'installer en virant l'autre avant (la tendance est à préférer aller vers le futur) et ensuite, il faut le placer en "hold" pour éviter que la prochaine mise à jour ne l'écrase.

Si ça marche pas niveau dépendances, prendre le paquet source et le recompiler un peu comme un backport vers le futur, pour pouvoir l'installer.

A+


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#3 20/11/2013 11:24:03

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Flash : Dépassement matériel !

Merci beaucoup !

Comment doit-on procéder pour installer en "hold" ?

Comment on recompile un paquet ? (Si tu sais ça parfaitement, merci, sinon je trouverais bien sur le ouaîbe en cherchant un peu.)

(Il faut tout me dire, je ne suis pas informaticien !)

Hors ligne

#4 20/11/2013 16:00:25

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Flash : Dépassement matériel !

Pour le passer en hold, après avoir réussi a correctement installé le paquet :

D'abord je récupère la liste des paquets au format "nom_paquet état"  dans un fichier :

dpkg --get-selections > paquets.list

Ensuite, j'édite le fichier "paquets.list" et je change la 2ème colone pour le paquet que je veux mettre en hold de "install" à "hold"

Enfin j'applique la modif :

dpkg --set-selections < paquets.list

Pour la recompilation :

  1. Mettre la bonne ligne "deb-src" de la distribution qui va bien dans /etc/apt/source.list

  2. apt-get update

  3. Dans un répertoire vide en user normal, apt-get source mon_paquet

  4. Dans le répertoire du source : dpkg-buildpackage -b -uc

  5. Y'a plus qu'à faire : dpkg -i ../mon_paquet....deb

S'il manque des dépendances, il faut faire "apt-get build-dep mon_paquet" pour qu'il les installent

S'il faut modifier des versions de dépendances, ça devient chaud, là faut commencer à éditer le "debian/control" du paquet...

A+


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#5 22/11/2013 16:13:42

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Flash : Dépassement matériel !

Merci beaucoup, mon problème est résolu (quoique de manière non satisfaisante mais ça ira.)

J'ai bien trouvé le paquet pour squeeze de flashplugin-nonfree mais en version tar.gz, la version .deb semblant introuvable. Je ne suis pas parvenu à l'installer car il faudrait savoir très exactement où il faut mettre les fichiers décompressés et tout ça est très confus (et peut-être dangereux !) 

Par contre j'ai trouvé un plugin alternatif browser-plugin-gnash plutot merdique (lent et limité en affichages ; C'est très inférieur à ce que j'avais avant!) mais qui fonctionne et c'est toujours ça  !
D'un autre coté il ne devrait pas y avoir de problème avec les mises à jour (rien à désactiver.)

Merci pour l'aide !

Hors ligne

#6 04/12/2013 11:16:32

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Flash : Dépassement matériel !

Retour sur la discussion (au cas ou quelqu'un aurait le même problème.)

J'ai changé de plugin alternatif : Il faut installer le paquet « get-flash-videos » . Non seulement ça fonctionne PARFAITEMENT, mais c'est mieux que le plug-in Adobe de base qui ne fonctionnait plus : Ce paquet offre des options en plus tel que l'enregistrement par exemple.

Hors ligne

Pied de page des forums