Andesi - forum

Forum francophone pour Debian

Vous n'êtes pas identifié(e).

#1 12/11/2013 20:20:23

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Ports USB non fonctionnels

Bonjour,

Après un changement des disques et une mise à jour système,
Mes ports USB ne fonctionnent plus !

la commande « lsusb »  renvoi « unable to initialize libusb: -99 »

à tout hasard j'ai réinstallé libusb, udev et usbutils mais ça ne vient pas d'eux !

Quelqu'un aurait-il une idée de ce qui se passe ? D'avance MERCI !

Hors ligne

#2 13/11/2013 09:22:54

armen
Membre
Lieu : 48°03'03" N - 04°59'55" W
Inscription : 09/03/2004
Messages : 1 938

Re : Ports USB non fonctionnels

Bonjour,

D'après cette page, le problème vient du "boot loader".

Dans le second message de la page citée ci-dessus, il y a un lien qui règlerait le problème.

Armen qui passe encore de temps en temps sur Andesi (mais qui ne voit pas grand monde :-( )


"La grandeur d'un métier est peut-etre, avant tout, d'unir des hommes : il n'est qu'un luxe véritable, et c'est celui des relations humaines." Antoine de Saint-Exupéry

Hors ligne

#3 13/11/2013 16:42:34

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Ports USB non fonctionnels

Merci pour ton aide !

Au bout du lien je n'ai pas comprit grand chose ; Tout est en anglais !  J'ai cru deviner qu'il fallait aller dans les paramètres GRUB (pas étonnant car effectivement j'avais eu des problèmes de démarrage et il avait fallut tripoter tout ça !)

J'ai modifié une ligne du /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
en
GRUB_CMDLINE_LINUX_DEFAULT="quiet  splash acpi=off" 

Hé bien rien ne change !

(Je n'ai pas oublié de faire un  « update-grub » )

Aurais-je oublié un truc ou mal comprit ?
___________________________________

à propos d'Andesi,

Le problème vient de ce qu'il est peu fréquenté en effet, donc les gens vont ailleurs... Et finalement il n'y a plus personne !  Pourtant on y trouve encore de l'aide !
Ailleurs c'est surtout les forums Ubuntu je pense bien que lorsqu'on a une distribution Debian il faille faire attention aux différences !

Hors ligne

#4 15/11/2013 13:35:11

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Ports USB non fonctionnels

Problème résolu entre temps !

En fait il y a un circuit de la carte-mère qui est tombé HS ( Confirmé par un démarrage sous knoppix : Cet OS de secours ne détecte plus l'USB !)

Solution : Montage d'une carte USB (de récup.) sur la carte mère. (Les prises de la carte remplacent ceux de la carte-mère.)

C'est plus lent et il faut brancher derrière mais au moins ça fonctionne !

Hors ligne

#5 15/11/2013 13:45:00

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Ports USB non fonctionnels

Et à propos de la ligne du /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
en
GRUB_CMDLINE_LINUX_DEFAULT="quiet  splash acpi=off"

Cela n'a pour effet de que de modifier l'arrêt de l'ordinateur !
« splash acpi=off » ordonne à l'ordinateur un simple "halt" au prochain arrêt (le système termine sur « Systeme halted » et il faut terminer l'arrêt à la main par le bouton d'arrêt. (Avantage il n'y a plus aucun circuit en veille.)
sans « splash acpi=off » l'ordinateur s'éteint complètement tout seul lorsqu'on le lui demande.

C'est toujours ça de découvert ! :-)

Hors ligne

#6 15/11/2013 13:47:48

armen
Membre
Lieu : 48°03'03" N - 04°59'55" W
Inscription : 09/03/2004
Messages : 1 938

Re : Ports USB non fonctionnels

Tu as de la chance dans ton malheur puisque la machine est encore fonctionnelle.

Cet été, j'ai des condensateurs qui ont lachés sur la carte mère (ils étaient gonflés et certains avaient perdu de la matière) --> poubelle (enfin, il faudrait que je l'emmène à la déchetterie. Je précise pour ceux qui allaient se déchainer sur cet inconscient qui jette ses déchets n'importe où).

Tu n'as pas une petite rallonge USB, c'est pas beau, mais utile si l'arrière n'est pas accessible.


"La grandeur d'un métier est peut-etre, avant tout, d'unir des hommes : il n'est qu'un luxe véritable, et c'est celui des relations humaines." Antoine de Saint-Exupéry

Hors ligne

#7 17/11/2013 19:23:54

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Ports USB non fonctionnels

Salut,

Pour compléter là dessus, le halt contre extinction en vrai, c'est effectivement l'ACPI. En gros, c'est un truc à peu près standard qui permet à l'os de gérer une parti du matériel et surtout son alimentation (en gros l'arrêt, la veille prolonlogée, ce genre de choses). A garder activé tant qu'on peut !


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#8 17/11/2013 23:32:25

Croa
Membre
Lieu : Biganos (Gironde)
Inscription : 07/02/2008
Messages : 46
Site Web

Re : Ports USB non fonctionnels

Merci à tous !

Je vais réactiver l'ACPI, au cas où ça gérerait des trucs importants.

Hors ligne

Pied de page des forums