Andesi - forum

Forum francophone pour Debian

Vous n'êtes pas identifié(e).

#1 06/09/2010 18:59:54

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

de lenny à squeeze

Ça fait deux fois que j'essaye de migrer de stable à testing.
À chaque fois la migration s'interrompt à la configuration d'udev,
précédée d'un problème de locales :

...
Processing triggers for man-db ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
...
manconv: can't set the locale; make sure $LC_* and $LANG are correct
Errors were encountered while processing:
 /var/cache/apt/archives/udev_160-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
#

Ci-dessous ce que me renvoie la commande locale :

# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Ne peut initialiser LC_ALL ? la locale par d?faut: Aucun fichier ou dossier de ce type
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Une idée, quelqu'un ?


*********** GPG : 45F03D8C ***********

Hors ligne

#2 06/09/2010 20:36:27

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : de lenny à squeeze

Je me réponds à moi-même :

# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libmpfr1ldbl cpp-4.3
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  udev
The following packages will be upgraded:
  udev
1 upgraded, 0 newly installed, 0 to remove and 661 not upgraded.
148 not fully installed or removed.
Need to get 0B/466kB of archives.
After this operation, 651kB of additional disk space will be used.
Do you want to continue [Y/n]? y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Ne peut initialiser LC_ALL ? la locale par d?faut: Aucun fichier ou dossier de ce type
Preconfiguring packages ...
Setting up libattr1 (1:2.4.44-2) ...
(Reading database ... 91521 files and directories currently installed.)
Preparing to replace udev 0.125-7+lenny3 (using .../archives/udev_160-1_i386.deb) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Ne peut initialiser LC_ALL ? la locale par d?faut: Aucun fichier ou dossier de ce type


Since release 150, udev requires that support for the CONFIG_SYSFS_DEPRECATED
feature is disabled in the running kernel.

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: error processing /var/cache/apt/archives/udev_160-1_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Errors were encountered while processing:
 /var/cache/apt/archives/udev_160-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Me voilà bien avancé.
J'essaye de revoir les locales :

# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Ne peut initialiser LC_ALL ? la locale par d?faut: Aucun fichier ou dossier de ce type
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed

Que faire ? Installer un nouveau  noyau, comme indiqué plus haut (Please upgrade your kernel before or while upgrading udev.) ?


*********** GPG : 45F03D8C ***********

Hors ligne

#3 07/09/2010 09:26:13

ioguix
Administrator
Lieu : Paris
Inscription : 25/04/2003
Messages : 3 945

Re : de lenny à squeeze

Salut,

As tu essayé de mettre à jour le paquet locales à la main justement ? avec un simple dpkg -i ?

Sinon, as-tu essayé de forcer les variables d'environnement de "apt-get -f install" ?

LANGUAGE=C LC_ALL=C LANG=C apt-get -f install

ioguix@jabber.org
"Contrairement aux chasseurs qui, eux, ne sont pas des lapins, les pollueurs, eux sont des ordures. - Philippe Geluck, Le chat"
gpg: 0828C222

Hors ligne

#4 07/09/2010 09:53:53

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : de lenny à squeeze

En fait je m'en suis sorti grâce à... synaptic !
Il m'indiquait que le paquet xserver-xorg-core était cassé.
J'ai supprimé celui-ci,
fait un joli aptitude safe-upgrade,
un petit dpkg-reconfigure locales,
réinstallé xserver-xorg...
et ça roule.

Et tant qu'à y être, me voilà utilisant le noyau 2.6.32,
ma carte ATI HD5750 fonctionne SANS ce maudit driver propriétaire,
bref : je me sens à la pointe du progrès.

Si ça se trouve, j'ai même le son qui fonctionne !

Merci pour ta réponse.


*********** GPG : 45F03D8C ***********

Hors ligne

Pied de page des forums