Andesi - forum

Forum francophone pour Debian

Vous n'êtes pas identifié(e).

#1 05/05/2010 00:08:24

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Carte son SB Audigy LS

Ben voilà, je n'ai pas de son.
Pourtant :

# lspci-v :

01:00.1 Audio device: ATI Technologies Inc Device aa58
    Subsystem: PC Partner Limited Device aa58
    Flags: bus master, fast devsel, latency 0, IRQ 5
    Memory at fbbfc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    Capabilities: [100] Vendor Specific Information <?>
    Capabilities: [150] Advanced Error Reporting <?>

...

01:00.1 Audio device: ATI Technologies Inc Device aa58
    Subsystem: PC Partner Limited Device aa58
    Flags: bus master, fast devsel, latency 0, IRQ 5
    Memory at fbbfc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    Capabilities: [100] Vendor Specific Information <?>
    Capabilities: [150] Advanced Error Reporting <?>

...

07:02.0 Multimedia audio controller: Creative Labs SB Audigy LS
    Subsystem: Creative Labs Device 100a
    Flags: bus master, medium devsel, latency 64, IRQ 17
    I/O ports at ec00 [size=32]
    Capabilities: [dc] Power Management version 2
    Kernel driver in use: CA0106
    Kernel modules: snd-ca0106

La carte est bien présente :

# asoundconf list
Names of available sound cards:
CA0106

... quoi que...

$ aplay -l
aplay: device_list:207: no soundcards found...

Mais bon, le système a l'air de se contenter de ça :

# alsaconf
Unloading ALSA sound driver modules: snd-ca0106 snd-seq-midi snd-seq-midi-event snd-rawmidi snd-ac97-codec snd-pcm snd-seq snd-timer snd-seq-device snd-page-alloc.
Building card database...


Loading driver...
Setting default volumes...


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!


#

C'est bien le module snd-ca0106 qui est censé s'occuper d'une telle carte, Mais je n'ai pas de son, et le contrôleur de volume s'obstine à me dire « Aucun greffon de contrôle de volume GStreamer et/ou périphériques trouvés ».
Quelqu'un saurait-il m'indiquer comment faire marcher ce bazar ?


*********** GPG : 45F03D8C ***********

Hors ligne

#2 05/05/2010 16:45:54

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Carte son SB Audigy LS

Salut,

Mes suggestions:
- regarde si tu as bien des modules snd-* chargés (lsmod)
- vérifie que s'est pas en "mute" (alsamixer)
- vérifie aussi les fichiers alsa* dans /etc/modprobe.d

Aussi est que tu es sûr que ta carte son est bien supporté par ton noyau?


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#3 05/05/2010 23:19:38

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : Carte son SB Audigy LS

Orgrim, merci pour tes réponses.

Pour la première :

$ lsmod | grep snd
snd_ca0106             27584  1 
snd_seq_midi            5728  0 
snd_seq_midi_event      6432  1 snd_seq_midi
snd_rawmidi            18496  2 snd_ca0106,snd_seq_midi
snd_ac97_codec         88452  1 snd_ca0106
snd_pcm                62660  2 snd_ca0106,snd_ac97_codec
snd_seq                41456  2 snd_seq_midi,snd_seq_midi_event
snd_timer              17800  2 snd_pcm,snd_seq
snd_seq_device          6380  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    45636  9 snd_ca0106,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore               6368  1 snd
ac97_bus                1728  1 snd_ac97_codec
snd_page_alloc          7816  2 snd_ca0106,snd_pcm

Pour la seconde, je n'avais pas exécuté alsamixer en root. C'est chose faite. Ça a l'air d'aller meiux, le contrôleur de volume fonctionne (à l'écran seulement, hélas).

Pour la troisième, /etc/modprobe.d m'a l'air plein de fichiers qui vont bien :

# ls /etc/modprobe.d/
aliases    alsa-base-blacklist    arch-aliases  display_class  libsane             pnp-hotplug
alsa-base  arch            blacklist     libpisock9     linux-sound-base_noOSS  sound

Je te passe les détails, mais alsa-base contient le driver, qui n'est pas blacklisté par ailleurs.

Pour ta dernière remarque : le codec est bien livré avec le noyau. À priori, il devrait fonctionner, non ?

Je n'ai pas avancé d'un poil. Ah, si :

$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device

Ainsi, un simple utilisateur ne peut accéder à alsamixer ?

Mieux encore :

$ aplay The\ Sinners\ -\ Watch\ Out.mp3 
aplay: main:564: audio open error: Aucun fichier ou répertoire de ce type

Ennuyeux, non ?
Mais totem démarre normalement.
D'autre part, si root essaie de lire un fichier son avec totem (!),
il obtient le pop-up suivant :

Erreur du greffon.
Impossible d'activer le greffon Media Player Keys.

Étrange, non ?

PS : je précise que je suis membre du groupe audio.


*********** GPG : 45F03D8C ***********

Hors ligne

#4 06/05/2010 12:26:39

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Carte son SB Audigy LS

Là je m'assurerais d'abord que le système ne voit qu'une carte, j'imagine que la carte ATI est fournie sur la carte mère? si oui, tu dois pouvoir la désactiver depuis le bios. Ensuite quand tu verras qu'une carte, relance alsaconf, il doit te proposer de choisir ta carte.


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#5 06/05/2010 15:57:17

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : Carte son SB Audigy LS

La carte ATI est une carte graphique... dont j'ai le plus grand mal à faire fonctionner le driver. Mais vu ci-dessus le résultat de lsmod, il me semble que c'est le driver ca0106 qui a pris la main sur les autres, non ?


*********** GPG : 45F03D8C ***********

Hors ligne

#6 06/05/2010 19:22:31

orgrim
Administrator
Lieu : Palaiseau
Inscription : 03/09/2005
Messages : 374
Site Web

Re : Carte son SB Audigy LS

C'est bizarre que ta carte graphique ATI soit marquée comme "Audio device"...


"First they ignore you, then they ridicule you, then they fight you, then you win."
  --  Mahatma Gandhi

Hors ligne

#7 13/05/2010 22:03:57

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : Carte son SB Audigy LS

orgrim a écrit :

C'est bizarre que ta carte graphique ATI soit marquée comme "Audio device"...

Peut-être... Mais :

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 1: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 2: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 3: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Malheureusement, j'ai toujours le message « audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback » qui s'affiche quand je veux tester le son via les préférences de Gnome...


*********** GPG : 45F03D8C ***********

Hors ligne

#8 06/07/2010 23:48:42

Gune
Membre
Lieu : Entre ici et ailleurs
Inscription : 20/03/2004
Messages : 469

Re : Carte son SB Audigy LS

Salut,

Est-ce que le paquet alsa-base est bien utile ? Il me semble que tu l'as d'installé.
Y'aurait pas un conflit entre ce qui est fourni avec alsa-base et les modules fournis avec le noyau ?
Enlever alsa-base pourrait peut-être fonctionner.

++

Gune

PS : Pour la carte ATI qui fait son, j'ai pareil. C'est lié au hdmi.

Hors ligne

#9 07/07/2010 12:33:09

pathe
Moderator
Lieu : shell (Seine et Marne)
Inscription : 21/11/2004
Messages : 815

Re : Carte son SB Audigy LS

Pour la carte ATI qui fait son, tu as pareil : certes.
Mais ton son sort d'où ? (car chez toi, je suis bien certain que ça marche)
Tu passes par ta carte mère, par ta carte graphique, par une carte son ?


*********** GPG : 45F03D8C ***********

Hors ligne

#10 09/07/2010 13:31:05

Gune
Membre
Lieu : Entre ici et ailleurs
Inscription : 20/03/2004
Messages : 469

Re : Carte son SB Audigy LS

Par « pareil », je pensais à la sortie du lspci et donc que cela n'était rien de bien grave.

Autrement mon son sort par une carte intégrée à la carte mère.
Je n'utilise pas alsa. Enfin si puisque ces pilotes sont inclus dans le noyau. C'est pour cela que je proposais de supprimer les paquets alsa-*, je pensais par là à un éventuel conflit entre les différents pilotes. Voilou.

Sinon j'ai lu sur un forum que quelqu'un utilisait l'emu10k1 comme pilote pour cette carte son, évidemment ça reste une information non vérifiée.

++

Dernière modification par Gune (09/07/2010 13:32:54)

Hors ligne

Pied de page des forums